Username:
Password:
Search for Plugins: Advanced
Please Sign in, Register or Resend Activation Email

Forums

  e107 Coders.org :: Forums :: E107 Plugins :: Q & A
 
<< Previous thread | Next thread >>  
HELP!!! upload error!!     Go to page       >>        
Author Post
stefanlyl
Sat Jul 01 2006, 03:53AM
Registered Member #55740
Joined: Sat Jul 01 2006, 01:56AM
Location:
Posts: 2
When i go to upload plugins i get the following error , An error has occurred, unable to un-archive the file PCLZIP extract error: 'PCLZIP_ERR_MISSING_FILE (-4)' can anyone help?
travick
Sat Jul 01 2006, 05:43PM
Registered Member #55779
Joined: Sat Jul 01 2006, 05:20PM
Location:
Posts: 1
me too :(
Back to top
Hellta
Sun Jul 09 2006, 09:25AM
Registered Member #56349
Joined: Sun Jul 09 2006, 09:12AM
Location:
Posts: 1
You need to extract the rar or zip before upload and do it seperatly. that should work then ^^
Back to top
420
Thu Jul 13 2006, 01:12PM
Registered Member #56268
Joined: Sat Jul 08 2006, 05:52AM
Location:
Posts: 3
theres no way to get it working properly? because its alot of extra work when you already have this EXCELLENT feature build in..but I get the same error message
Back to top
bugrain
Mon Jul 24 2006, 10:33PM

Registered Member #22953
Joined: Fri Mar 25 2005, 11:21AM
Location:
Posts: 1031
Is the file actually getting uploaded (can you see it)? If not, add ZIP files to the allowed upload file types (see e107_admin/filetypes.php).

If it is, do as Hellta says as the problem is with the server (no application to ubzip archives) and not e107's problem.
Back to top
Professor Inuyasha
Mon Sep 04 2006, 09:59PM
Registered Member #56249
Joined: Fri Jul 07 2006, 09:25PM
Location:
Posts: 4
bugrain wrote ...

Is the file actually getting uploaded (can you see it)? If not, add ZIP files to the allowed upload file types (see e107_admin/filetypes.php).

If it is, do as Hellta says as the problem is with the server (no application to ubzip archives) and not e107's problem.


no, you are wrong, it is e107's problem! 0.75 got problem with it....last time i used 0.72, upgraded to 73, 74, now 75, then i test on new website with 0.75 only....i got error...it must be 0.75's core fault!
Back to top
rblundon
Sun Dec 03 2006, 05:17AM
Registered Member #68348
Joined: Sat Dec 02 2006, 02:42PM
Location:
Posts: 1
Ok, so I had the same error and figured out the issue. It seems to be a bug, but it is easy enough to fix on your own. Go into the e107_admin folder and rename filetypes_.php to filetypes.php and you will be able to upload plugins again. I'll go post the bug on the main site.
Back to top
Niro
Mon Dec 04 2006, 08:14AM
Registered Member #56683
Joined: Wed Jul 12 2006, 11:42PM
Location: Tracing.... Please hold.... Tracing.... Location: NOT FOUND
Posts: 23
test

[ Edited Mon Dec 04 2006, 08:15AM ]
Back to top
Website
bugrain
Mon Dec 04 2006, 01:51PM

Registered Member #22953
Joined: Fri Mar 25 2005, 11:21AM
Location:
Posts: 1031
Professor Inuyasha wrote ...

bugrain wrote ...

Is the file actually getting uploaded (can you see it)? If not, add ZIP files to the allowed upload file types (see e107_admin/filetypes.php).

If it is, do as Hellta says as the problem is with the server (no application to ubzip archives) and not e107's problem.


no, you are wrong, it is e107's problem! 0.75 got problem with it....last time i used 0.72, upgraded to 73, 74, now 75, then i test on new website with 0.75 only....i got error...it must be 0.75's core fault!


Well, I beg to differ. If it is not working and filetypes.php allows ZIP files then it is a server issue. Maybe e107 could handle this better, to indicate that there is no application available to unzip the files, but that's about it.

rblundon wrote ...

Ok, so I had the same error and figured out the issue. It seems to be a bug, but it is easy enough to fix on your own. Go into the e107_admin folder and rename filetypes_.php to filetypes.php and you will be able to upload plugins again. I'll go post the bug on the main site.


This is not a bug, it's intended to be like this. By default, e107 allows no file types to be uploaded. You are supposed to rename filetypes_.php to filetypes.php if you want to allow files to be uploaded and you should edit this file to allow only those file types that you want to be uploaded.
Back to top
TjetjepRB
Mon Dec 25 2006, 03:55PM
Registered Member #69527
Joined: Mon Dec 18 2006, 08:22PM
Location:
Posts: 1
When i go to upload plugins i get the following error , An error has occurred, unable to un-archive the file PCLZIP extract error: 'PCLZIP_ERR_MISSING_FILE (-4)' can anyone help?

Solution :
You can find file in the \e107\e107_admin\filetypes_.php. So, rename the file from filetypes_.php to filetypes.php.
With this case (my problem) that solution can work properly. That is my experience. Good Luck!
Back to top
Go to page       >>   

Jump:     Back to top

Syndicate this thread: rss 0.92 Syndicate this thread: rss 2.0 Syndicate this thread: RDF
Powered by e107 Forum System
Render time: 2.6012 sec, 2.2988 of that for queries. DB queries: 53.